PSWriteNetLib

PSWriteNetLib For CLR 1.1 Documentation

PSWriteNetLib Namespace

Namespace hierarchy

Classes

Class | Description
BoundingBox | An object that defines a bounding box on a PostScript form.
DocumentCompleteEventArgs | An event arg that contains the total page count that were written in the PostScript document.
PageCreatedEventArgs | An event args that contains the page number of the new page in the document.
PointS | An object that contains X and Y cooridnates useful for location items in PostScript page descriptions.
PSColor | Provides an encapsulation of grayscale, rgb and cmyk colorspaces and color sets in PostScript page descriptions.
PSDocument | Encapsulates a PostScript document. Creates a PostScript output file that contains the PostScript code for a page description.
PSForm | Provides a cached form object that is only written once to the underlying PostScript file and can be called unlimited times. Saves memory and reduces output file size.
PSFormBase | Provides a core object used by PSWriteLib. Not intended to by used directly from your code.
PSImage | Provides a class that encapsulates an image that can be drawn into a PSDocument or into a PSForm object.
TMatrix | Provides a transformation matrix object that can manipulate the current user space to do translations(moving the point of origin), scaling and rotations about the point of origin.

Structures

Structure | Description
PSDocument.PieChart | Structure that defines a pie chart.
PSDocument.PieChartSlice | Structure that defines a single slice of a pie chart.

Delegates

Delegate | Description
PSDocument.Document_CompleteEventHandler |
PSDocument.NewPage_CreatedEventHandler |

Enumerations

Enumeration | Description
PSDocument.DocumentOrientation | Value that determines the normal orientation of this page description.
PSDocument.LineCap | Value that determines how to draw the ends of lines.
PSDocument.LineJoin | Value that determines the kind of joints to make between lines.
PSDocument.PaperSize | Value that indicates the standard paper size for this page description.

Send comments on this topic.

Copyright 2005, 2006 Fractured Thinking. All Rights Reserved.


BoundingBox Class

An object that defines a bounding box on a PostScript form.

For a list of all members of this type, see BoundingBox Members.

System.Object
PSWriteNetLib.BoundingBox

[Visual Basic]
Public Class BoundingBox
[C#]
public class BoundingBox

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

BoundingBox Members | PSWriteNetLib Namespace

Send comments on this topic.

Copyright 2005, 2006 Fractured Thinking. All Rights Reserved.

Generated from assembly PSWriteNet [1.0.1.0]


BoundingBox Members

BoundingBox overview

Public Instance Constructors

BoundingBox Constructor Gets a new BoundingBox object whose members are set.

Public Instance Properties

Height | Gets a value that describes the height of the bounding box.
Origin | Gets a PointS object containing X and Y coordinates for the origin location of the bound box. Normally 0, 0.
Width | Gets a value that describes the width of the bounding box.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

BoundingBox Class | PSWriteNetLib Namespace


BoundingBox Constructor

Gets a new BoundingBox object whose members are set.

[Visual Basic]
Public Sub New( _
ByVal origin As PointS, _
ByVal height As Single, _
ByVal width As Single _
)
[C#]
public BoundingBox(
PointS origin,
float height,
float width
);

Parameters

origin
PointS object containing the X and Y coordinates for the origin of the bounding box. Normally 0,0.
height
Height of the bounding box in points.
width
Width of the bounding box in points.

Remarks

See Also

BoundingBox Class | PSWriteNetLib Namespace


BoundingBox Properties

The properties of the BoundingBox class are listed below. For a complete list of BoundingBox class members, see the BoundingBox Members topic.

Public Instance Properties

Height | Gets a value that describes the height of the bounding box.
Origin | Gets a PointS object containing X and Y coordinates for the origin location of the bound box. Normally 0, 0.
Width | Gets a value that describes the width of the bounding box.

See Also

BoundingBox Class | PSWriteNetLib Namespace


Height Property

PSWriteNetLib For CLR 1.1 Documentation

BoundingBox.Height Property

Gets a value that describes the height of the bounding box.

[Visual Basic]
Public ReadOnly Property Height As Single
[C#]
public float Height {get;}

Property Value

Remarks

See Also

BoundingBox Class | PSWriteNetLib Namespace


Origin Property

PSWriteNetLib For CLR 1.1 Documentation

BoundingBox.Origin Property

Gets a PointS object containing X and Y coordinates for the origin location of the bound box. Normally 0, 0.

[Visual Basic]
Public ReadOnly Property Origin As PointS
[C#]
public PointS Origin {get;}

Property Value

Remarks

See Also

BoundingBox Class | PSWriteNetLib Namespace


Width Property

PSWriteNetLib For CLR 1.1 Documentation

BoundingBox.Width Property

Gets a value that describes the width of the bounding box.

[Visual Basic]
Public ReadOnly Property Width As Single
[C#]
public float Width {get;}

Property Value

Remarks

See Also

BoundingBox Class | PSWriteNetLib Namespace


DocumentCompleteEventArgs Class

An event arg that contains the total page count that were written in the PostScript document.

For a list of all members of this type, see DocumentCompleteEventArgs Members.

System.Object
System.EventArgs
PSWriteNetLib.DocumentCompleteEventArgs

[Visual Basic]
Public Class DocumentCompleteEventArgs
Inherits EventArgs
[C#]
public class DocumentCompleteEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Raised when a document is complete.

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

DocumentCompleteEventArgs Members | PSWriteNetLib Namespace


DocumentCompleteEventArgs Members

DocumentCompleteEventArgs overview

Public Instance Constructors

DocumentCompleteEventArgs Constructor Gets a new instance of DocumentCompletedEventArgs with its member set.

Public Instance Properties

PageCount Gets the number of pages in the document.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

DocumentCompleteEventArgs Class | PSWriteNetLib Namespace


DocumentCompleteEventArgs Constructor

Gets a new instance of DocumentCompletedEventArgs with its member set.

[Visual Basic]
Public Sub New( _
ByVal pgCount As Integer _
)
[C#]
public DocumentCompleteEventArgs(
int pgCount
);

Parameters

pgCount

Remarks

See Also

DocumentCompleteEventArgs Class | PSWriteNetLib Namespace


DocumentCompleteEventArgs Properties

The properties of the DocumentCompleteEventArgs class are listed below. For a complete list of DocumentCompleteEventArgs class members, see the DocumentCompleteEventArgs Members topic.

Public Instance Properties

PageCount Gets the number of pages in the document.

See Also

DocumentCompleteEventArgs Class | PSWriteNetLib Namespace


PageCount Property

PSWriteNetLib For CLR 1.1 Documentation

DocumentCompleteEventArgs.PageCount Property

Gets the number of pages in the document.

[Visual Basic]
Public ReadOnly Property PageCount As Integer
[C#]
public int PageCount {get;}

Property Value

Remarks

See Also

DocumentCompleteEventArgs Class | PSWriteNetLib Namespace


PageCreatedEventArgs Class

An event args that contains the page number of the new page in the document.

For a list of all members of this type, see PageCreatedEventArgs Members.

System.Object
System.EventArgs
PSWriteNetLib.PageCreatedEventArgs

[Visual Basic]
Public Class PageCreatedEventArgs
Inherits EventArgs
[C#]
public class PageCreatedEventArgs : EventArgs

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PageCreatedEventArgs Members | PSWriteNetLib Namespace


PageCreatedEventArgs Members

PageCreatedEventArgs overview

Public Instance Constructors

PageCreatedEventArgs Constructor Gets a new PageCreatedEventArgs object with its member set.

Public Instance Properties

CurrentPageNumber Gets the page number of the new page in the document.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PageCreatedEventArgs Class | PSWriteNetLib Namespace


PageCreatedEventArgs Constructor

Gets a new PageCreatedEventArgs object with its member set.

[Visual Basic]
Public Sub New( _
ByVal newPgNum As Integer _
)
[C#]
public PageCreatedEventArgs(
int newPgNum
);

Parameters

newPgNum

Remarks

See Also

PageCreatedEventArgs Class | PSWriteNetLib Namespace


PageCreatedEventArgs Properties

The properties of the PageCreatedEventArgs class are listed below. For a complete list of PageCreatedEventArgs class members, see the PageCreatedEventArgs Members topic.

Public Instance Properties

CurrentPageNumber Gets the page number of the new page in the document.

See Also

PageCreatedEventArgs Class | PSWriteNetLib Namespace


CurrentPageNumber Property

PSWriteNetLib For CLR 1.1 Documentation

PageCreatedEventArgs.CurrentPageNumber Property

Gets the page number of the new page in the document.

[Visual Basic]
Public ReadOnly Property CurrentPageNumber As Integer
[C#]
public int CurrentPageNumber {get;}

Property Value

Remarks

See Also

PageCreatedEventArgs Class | PSWriteNetLib Namespace


PointS Class

An object that contains X and Y cooridnates useful for location items in PostScript page descriptions.

For a list of all members of this type, see PointS Members.

System.Object
PSWriteNetLib.PointS

[Visual Basic]
NotInheritable Public Class PointS
[C#]
public sealed class PointS

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PointS Members | PSWriteNetLib Namespace


PointS Members

PointS overview

Public Instance Constructors

PointS Overloaded. Initializes a new instance of the PointS class.

Public Instance Properties

X | Gets or sets the horizontal axis position on the plane.
Y | Gets or sets the vertical axis position on the plane.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmpty | Tests to see if any value of this object is greater than 0.
ToPointF | Returns a new PointF object that has the same values as this PointS object.
ToString | Returns a string representation of the values of this object.

See Also

PointS Class | PSWriteNetLib Namespace


PointS Constructor

Returns a default PointS object.

Overload List

Returns a default PointS object.

public PointS();

Returns a PointS object with its members set.

public PointS(float,float);

See Also

PointS Class | PSWriteNetLib Namespace


PointS Constructor ()

Returns a default PointS object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PointS();

Remarks

See Also

PointS Class | PSWriteNetLib Namespace | PointS Constructor Overload List


PointS Constructor (Single, Single)

Returns a PointS object with its members set.

[Visual Basic]
Overloads Public Sub New( _
ByVal x As Single, _
ByVal y As Single _
)
[C#]
public PointS(
float x,
float y
);

Parameters

x
Horizontal axis location
y
Vertical location

Remarks

See Also

PointS Class | PSWriteNetLib Namespace | PointS Constructor Overload List


PointS Properties

The properties of the PointS class are listed below. For a complete list of PointS class members, see the PointS Members topic.

Public Instance Properties

X | Gets or sets the horizontal axis position on the plane.
Y | Gets or sets the vertical axis position on the plane.

See Also

PointS Class | PSWriteNetLib Namespace


X Property

PSWriteNetLib For CLR 1.1 Documentation

PointS.X Property

Gets or sets the horizontal axis position on the plane.

[Visual Basic]
Public Property X As Single
[C#]
public float X {get; set;}

Property Value

Remarks

See Also

PointS Class | PSWriteNetLib Namespace


Y Property

PSWriteNetLib For CLR 1.1 Documentation

PointS.Y Property

Gets or sets the vertical axis position on the plane.

[Visual Basic]
Public Property Y As Single
[C#]
public float Y {get; set;}

Property Value

Remarks

See Also

PointS Class | PSWriteNetLib Namespace


PointS Methods

The methods of the PointS class are listed below. For a complete list of PointS class members, see the PointS Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IsEmpty | Tests to see if any value of this object is greater than 0.
ToPointF | Returns a new PointF object that has the same values as this PointS object.
ToString | Returns a string representation of the values of this object.

See Also

PointS Class | PSWriteNetLib Namespace


PointS.IsEmpty Method

Tests to see if any value of this object is greater than 0.

[Visual Basic]
Public Function IsEmpty() As Boolean
[C#]
public bool IsEmpty();

Return Value

Remarks

See Also

PointS Class | PSWriteNetLib Namespace


PointS.ToPointF Method

Returns a new PointF object that has the same values as this PointS object.

[Visual Basic]
Public Function ToPointF() As PointF
[C#]
public PointF ToPointF();

Return Value

Remarks

See Also

PointS Class | PSWriteNetLib Namespace


PointS.ToString Method

Returns a string representation of the values of this object.

[Visual Basic]
Overrides Public Function ToString() As String
[C#]
public override string ToString();

Return Value

Remarks

See Also

PointS Class | PSWriteNetLib Namespace


PSColor Class

Provides an encapsulation of grayscale, rgb and cmyk colorspaces and color sets in PostScript page descriptions.

For a list of all members of this type, see PSColor Members.

System.Object
PSWriteNetLib.PSColor

[Visual Basic]
NotInheritable Public Class PSColor
[C#]
public sealed class PSColor

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSColor Members | PSWriteNetLib Namespace


PSColor Members

PSColor overview

Public Instance Constructors

PSColor Overloaded. Initializes a new instance of the PSColor class.

Public Instance Properties

Black | Gets the value of the black color component. 0 (no ink) to 255 (100% ink).
Blue | Gets the value of the blue color component. 0 (no ink) to 255 (100% ink).
Cyan | Gets the value of the cyan color component. 0 (no ink) to 255 (100% ink).
Gray | Gets the value of the grayscale color component. 0 (black) to 255 (white).
Green | Gets the value of the green color component. 0 (no ink) to 255 (100% ink).
Magenta | Gets the value of the magenta color component. 0 (no ink) to 255 (100% ink).
Red | Gets the value of the red color component. 0 (no ink) to 255 (100% ink).
Yellow | Gets the value of the yellow color component. 0 (no ink) to 255 (100% ink).

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCMYKColor | Sets the color components to create a CMYK based color.
SetGrayColor | Sets the colors components to create a grayscale color.
SetRGBColor | Sets the color components to create a RGB based color.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor Constructor

Returns a new grayscale color.

Overload List

Returns a new grayscale color.

public PSColor(byte);

Returns a new RGB color.

public PSColor(byte,byte,byte);

Returns a new CMYK color.

public PSColor(byte,byte,byte,byte);

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor Constructor (Byte)

Returns a new grayscale color.

[Visual Basic]
Overloads Public Sub New( _
ByVal gray As Byte _
)
[C#]
public PSColor(
byte gray
);

Parameters

gray
0 (black) to 255 (white)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace | PSColor Constructor Overload List


PSColor Constructor (Byte, Byte, Byte)

Returns a new RGB color.

[Visual Basic]
Overloads Public Sub New( _
ByVal red As Byte, _
ByVal green As Byte, _
ByVal blue As Byte _
)
[C#]
public PSColor(
byte red,
byte green,
byte blue
);

Parameters

red
0 (no ink) to 255 (100% ink)
green
0 (no ink) to 255 (100% ink)
blue
0 (no ink) to 255 (100% ink)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace | PSColor Constructor Overload List


PSColor Constructor (Byte, Byte, Byte, Byte)

Returns a new CMYK color.

[Visual Basic]
Overloads Public Sub New( _
ByVal cyan As Byte, _
ByVal magenta As Byte, _
ByVal yellow As Byte, _
ByVal black As Byte _
)
[C#]
public PSColor(
byte cyan,
byte magenta,
byte yellow,
byte black
);

Parameters

cyan
0 (no ink) to 255 (100% ink)
magenta
0 (no ink) to 255 (100% ink)
yellow
0 (no ink) to 255 (100% ink)
black
0 (no ink) to 255 (100% ink)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace | PSColor Constructor Overload List


PSColor Properties

The properties of the PSColor class are listed below. For a complete list of PSColor class members, see the PSColor Members topic.

Public Instance Properties

Black | Gets the value of the black color component. 0 (no ink) to 255 (100% ink).
Blue | Gets the value of the blue color component. 0 (no ink) to 255 (100% ink).
Cyan | Gets the value of the cyan color component. 0 (no ink) to 255 (100% ink).
Gray | Gets the value of the grayscale color component. 0 (black) to 255 (white).
Green | Gets the value of the green color component. 0 (no ink) to 255 (100% ink).
Magenta | Gets the value of the magenta color component. 0 (no ink) to 255 (100% ink).
Red | Gets the value of the red color component. 0 (no ink) to 255 (100% ink).
Yellow | Gets the value of the yellow color component. 0 (no ink) to 255 (100% ink).

See Also

PSColor Class | PSWriteNetLib Namespace


Black Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Black Property

Gets the value of the black color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Black As Byte
[C#]
public byte Black {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Blue Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Blue Property

Gets the value of the blue color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Blue As Byte
[C#]
public byte Blue {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Cyan Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Cyan Property

Gets the value of the cyan color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Cyan As Byte
[C#]
public byte Cyan {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Gray Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Gray Property

Gets the value of the grayscale color component. 0 (black) to 255 (white).

[Visual Basic]
Public ReadOnly Property Gray As Byte
[C#]
public byte Gray {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Green Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Green Property

Gets the value of the green color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Green As Byte
[C#]
public byte Green {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Magenta Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Magenta Property

Gets the value of the magenta color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Magenta As Byte
[C#]
public byte Magenta {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Red Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Red Property

Gets the value of the red color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Red As Byte
[C#]
public byte Red {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


Yellow Property

PSWriteNetLib For CLR 1.1 Documentation

PSColor.Yellow Property

Gets the value of the yellow color component. 0 (no ink) to 255 (100% ink).

[Visual Basic]
Public ReadOnly Property Yellow As Byte
[C#]
public byte Yellow {get;}

Property Value

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor Methods

The methods of the PSColor class are listed below. For a complete list of PSColor class members, see the PSColor Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
SetCMYKColor | Sets the color components to create a CMYK based color.
SetGrayColor | Sets the colors components to create a grayscale color.
SetRGBColor | Sets the color components to create a RGB based color.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor.SetCMYKColor Method

Sets the color components to create a CMYK based color.

[Visual Basic]
Public Function SetCMYKColor( _
ByVal cyan As Byte, _
ByVal magenta As Byte, _
ByVal yellow As Byte, _
ByVal black As Byte _
) As Boolean
[C#]
public bool SetCMYKColor(
byte cyan,
byte magenta,
byte yellow,
byte black
);

Parameters

cyan
0 (no ink) to 255 (100% ink)
magenta
0 (no ink) to 255 (100% ink)
yellow
0 (no ink) to 255 (100% ink)
black
0 (no ink) to 255 (100% ink)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor.SetGrayColor Method

Sets the colors components to create a grayscale color.

[Visual Basic]
Public Function SetGrayColor( _
ByVal gray As Byte _
) As Boolean
[C#]
public bool SetGrayColor(
byte gray
);

Parameters

gray
0 (no ink) to 255 (100% ink)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


PSColor.SetRGBColor Method

Sets the color components to create a RGB based color.

[Visual Basic]
Public Function SetRGBColor( _
ByVal red As Byte, _
ByVal green As Byte, _
ByVal blue As Byte _
) As Boolean
[C#]
public bool SetRGBColor(
byte red,
byte green,
byte blue
);

Parameters

red
0 (no ink) to 255 (100% ink)
green
0 (no ink) to 255 (100% ink)
blue
0 (no ink) to 255 (100% ink)

Remarks

See Also

PSColor Class | PSWriteNetLib Namespace


PSDocument Class

Encapsulates a PostScript document. Creates a PostScript output file that contains the PostScript code for a page description.

For a list of all members of this type, see PSDocument Members.

System.Object
PSWriteNetLib.PSDocument

[Visual Basic]
NotInheritable Public Class PSDocument
[C#]
public sealed class PSDocument

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSDocument Members | PSWriteNetLib Namespace


PSDocument Members

PSDocument overview

Public Instance Constructors

PSDocument Constructor Gets a new PSDocument object. Requires a path name to the output PostScript file that will contain a page description.

Public Instance Properties

CurrentPaperSource | Gets a string describing the media for the current page.
DocumentCopyright | Gets or sets the copyright that will be written inside the page description. Not visible to end user.
DocumentInProgress | Gets a value that indicates whether document drawing has begun.
Duplex | Gets a value that determines if the document will be printed on both sides of the media.
NewPaperSource | Gets a string describing the media for the next page.
Orientation | Gets a value that determines the orientation of the current page.
PageCount | Gets the number of pages, single side, in this page desciption.
PageHeight | Gets the height of the current page in points.
PageSize | Gets a value that determines the standard paper size of the document.
PageWidth | Gets the width of the current page in points.
PSForms | Gets the collection of PSForms in this page description.
PSOutputFileName | Gets the absolute path and file name of the output file being generated.
Tumble | Gets a value that indicates whether alternate pages will be inverted if duplex is true. Used when duplex printing and when the document will be bound at the top.

Public Instance Methods

AddPrintJobLanguageInstructions | Replaces the default array of Print Job Language instructions with a custom array. You can alter the PJL used at the top of output files by utilizing this method.
ChangeInk | Changes the color of ink in the current graphics object of the current PostScript document.
ChangePaperSource |
CleanString | Cleans the passed in string of special characters that have special meaning in postscript.
DefineEmbeddedFont | Defines a non-resident font that will be used in the document with a path to a PFA font file.
DefineEmbeddedFontCnt | Defines a non-resident font that will be used in the document. Uses the contents of a PFA font file directly.
DefineFont | Defines a font that is installed onto the target PostScript device. (Resident font).
DefinePieChart | Defines a pie chart structure that will be called for in the document.
DrawCircle | Overloaded. Draws an unfilled circle onto the document.
DrawDashedLine | Draws a dashed line onto the document.
DrawPieChart | Causes a pie chart to be drawn on the document centered on the point identified by center.
DrawRdRectangle | Overloaded. Draws a filled rectangle with rounded corners.
DrawRectangle | Overloaded. Draw an unfilled rectangle onto the document.
DrawSolidLine | Draws a solid line onto the document.
EndDoc |
EndPage |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartDoc | Initializes the library and begins the construction of a PostScript page description. Required call.
StartPage | Required call. Make this call when starting a new page in the document. Set useSave to true to save memory on the device.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteCommentLine | Writes a comment into the page description at the current file pointer location. Comments are ignored by all PostScript devices.
WriteForm | Overloaded. Causes the specified PostScript form to be drawn at location 0,0 on the document. This is intended for full page forms. Use another overload to write a form at a specific location.
WriteImage | Writes a PSImage object to the document at a specified location.
WriteParagraph | Writes a paragraph to the document automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.
WritePostNetBarCode | Draws a PostNet bar code onto the document at the location specied.
WriteRaw | Writes a single line of raw PostScript code into the output file at the current file position.
WriteString | Overloaded. Writes text onto the document. Does not change font size or font name.
WriteStringCN | Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.
WriteStringRJ | Writes text to the document right-justified. Specifies font name and size.
WriteStringUL | Writes underlined text onto the document. Specifies font name and size

Public Instance Events

Document_Complete
NewPage_Created

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument Constructor

Gets a new PSDocument object. Requires a path name to the output PostScript file that will contain a page description.

[Visual Basic]
Public Sub New( _
ByVal outputFilePathAndName As String _
)
[C#]
public PSDocument(
string outputFilePathAndName
);

Parameters

outputFilePathAndName
Absolute path and file name of the desired output file.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument Properties

The properties of the PSDocument class are listed below. For a complete list of PSDocument class members, see the PSDocument Members topic.

Public Instance Properties

CurrentPaperSource | Gets a string describing the media for the current page.
DocumentCopyright | Gets or sets the copyright that will be written inside the page description. Not visible to end user.
DocumentInProgress | Gets a value that indicates whether document drawing has begun.
Duplex | Gets a value that determines if the document will be printed on both sides of the media.
NewPaperSource | Gets a string describing the media for the next page.
Orientation | Gets a value that determines the orientation of the current page.
PageCount | Gets the number of pages, single side, in this page desciption.
PageHeight | Gets the height of the current page in points.
PageSize | Gets a value that determines the standard paper size of the document.
PageWidth | Gets the width of the current page in points.
PSForms | Gets the collection of PSForms in this page description.
PSOutputFileName | Gets the absolute path and file name of the output file being generated.
Tumble | Gets a value that indicates whether alternate pages will be inverted if duplex is true. Used when duplex printing and when the document will be bound at the top.

See Also

PSDocument Class | PSWriteNetLib Namespace


CurrentPaperSource Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.CurrentPaperSource Property

Gets a string describing the media for the current page.

[Visual Basic]
Public ReadOnly Property CurrentPaperSource As String
[C#]
public string CurrentPaperSource {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


DocumentCopyright Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.DocumentCopyright Property

Gets or sets the copyright that will be written inside the page description. Not visible to end user.

[Visual Basic]
Public Property DocumentCopyright As String
[C#]
public string DocumentCopyright {get; set;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


DocumentInProgress Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.DocumentInProgress Property

Gets a value that indicates whether document drawing has begun.

[Visual Basic]
Public ReadOnly Property DocumentInProgress As Boolean
[C#]
public bool DocumentInProgress {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


Duplex Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.Duplex Property

Gets a value that determines if the document will be printed on both sides of the media.

[Visual Basic]
Public ReadOnly Property Duplex As Boolean
[C#]
public bool Duplex {get;}

Property Value

Remarks

This setting will be meaningless on PostScript devices that do not support duplex(printing on both sides of paper) printing.

See Also

PSDocument Class | PSWriteNetLib Namespace


NewPaperSource Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.NewPaperSource Property

Gets a string describing the media for the next page.

[Visual Basic]
Public ReadOnly Property NewPaperSource As String
[C#]
public string NewPaperSource {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


Orientation Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.Orientation Property

Gets a value that determines the orientation of the current page.

[Visual Basic]
Public ReadOnly Property Orientation As DocumentOrientation
[C#]
public PSDocument.DocumentOrientation Orientation {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PageCount Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PageCount Property

Gets the number of pages, single side, in this page desciption.

[Visual Basic]
Public ReadOnly Property PageCount As Long
[C#]
public long PageCount {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PageHeight Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PageHeight Property

Gets the height of the current page in points.

[Visual Basic]
Public ReadOnly Property PageHeight As Single
[C#]
public float PageHeight {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PageSize Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PageSize Property

Gets a value that determines the standard paper size of the document.

[Visual Basic]
Public ReadOnly Property PageSize As PaperSize
[C#]
public PSDocument.PaperSize PageSize {get;}

Property Value

Remarks

Paper size cannot be changed after calling StartDoc().

See Also

PSDocument Class | PSWriteNetLib Namespace


PageWidth Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PageWidth Property

Gets the width of the current page in points.

[Visual Basic]
Public ReadOnly Property PageWidth As Single
[C#]
public float PageWidth {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSForms Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PSForms Property

Gets the collection of PSForms in this page description.

[Visual Basic]
Public ReadOnly Property PSForms As ArrayList
[C#]
public System.Collections.ArrayList PSForms {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSOutputFileName Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.PSOutputFileName Property

Gets the absolute path and file name of the output file being generated.

[Visual Basic]
Public ReadOnly Property PSOutputFileName As String
[C#]
public string PSOutputFileName {get;}

Property Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


Tumble Property

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.Tumble Property

Gets a value that indicates whether alternate pages will be inverted if duplex is true. Used when duplex printing and when the document will be bound at the top.

[Visual Basic]
Public ReadOnly Property Tumble As Boolean
[C#]
public bool Tumble {get;}

Property Value

Remarks

Tumbling is when a duplex document is bound at the top so that alternate pages must be printed upside-down so that when viewed, after being bound, they will be right-side up.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument Methods

The methods of the PSDocument class are listed below. For a complete list of PSDocument class members, see the PSDocument Members topic.

Public Instance Methods

AddPrintJobLanguageInstructions | Replaces the default array of Print Job Language instructions with a custom array. You can alter the PJL used at the top of output files by utilizing this method.
ChangeInk | Changes the color of ink in the current graphics object of the current PostScript document.
ChangePaperSource |
CleanString | Cleans the passed in string of special characters that have special meaning in postscript.
DefineEmbeddedFont | Defines a non-resident font that will be used in the document with a path to a PFA font file.
DefineEmbeddedFontCnt | Defines a non-resident font that will be used in the document. Uses the contents of a PFA font file directly.
DefineFont | Defines a font that is installed onto the target PostScript device. (Resident font).
DefinePieChart | Defines a pie chart structure that will be called for in the document.
DrawCircle | Overloaded. Draws an unfilled circle onto the document.
DrawDashedLine | Draws a dashed line onto the document.
DrawPieChart | Causes a pie chart to be drawn on the document centered on the point identified by center.
DrawRdRectangle | Overloaded. Draws a filled rectangle with rounded corners.
DrawRectangle | Overloaded. Draw an unfilled rectangle onto the document.
DrawSolidLine | Draws a solid line onto the document.
EndDoc |
EndPage |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
StartDoc | Initializes the library and begins the construction of a PostScript page description. Required call.
StartPage | Required call. Make this call when starting a new page in the document. Set useSave to true to save memory on the device.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteCommentLine | Writes a comment into the page description at the current file pointer location. Comments are ignored by all PostScript devices.
WriteForm | Overloaded. Causes the specified PostScript form to be drawn at location 0,0 on the document. This is intended for full page forms. Use another overload to write a form at a specific location.
WriteImage | Writes a PSImage object to the document at a specified location.
WriteParagraph | Writes a paragraph to the document automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.
WritePostNetBarCode | Draws a PostNet bar code onto the document at the location specied.
WriteRaw | Writes a single line of raw PostScript code into the output file at the current file position.
WriteString | Overloaded. Writes text onto the document. Does not change font size or font name.
WriteStringCN | Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.
WriteStringRJ | Writes text to the document right-justified. Specifies font name and size.
WriteStringUL | Writes underlined text onto the document. Specifies font name and size

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.AddPrintJobLanguageInstructions Method

Replaces the default array of Print Job Language instructions with a custom array. You can alter the PJL used at the top of output files by utilizing this method.

[Visual Basic]
Public Sub AddPrintJobLanguageInstructions( _
ByVal pjlLinesArray As String() _
)
[C#]
public void AddPrintJobLanguageInstructions(
string[] pjlLinesArray
);

Parameters

pjlLinesArray
An array of PJL instructions to replace the default ones with.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.ChangeInk Method

Changes the color of ink in the current graphics object of the current PostScript document.

[Visual Basic]
Public Sub ChangeInk( _
ByVal newInk As PSColor _
)
[C#]
public void ChangeInk(
PSColor newInk
);

Parameters

newInk
PSColor object containing color information.

Remarks

Changing ink color is meaningful only for text operations. Drawing operations require PSColor parameters and are separate from graphics drawing operations.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.ChangePaperSource Method

[Visual Basic]
Public Sub ChangePaperSource( _
ByVal newSource As String _
)
[C#]
public void ChangePaperSource(
string newSource
);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.CleanString Method

Cleans the passed in string of special characters that have special meaning in postscript.

[Visual Basic]
Public Function CleanString( _
ByVal str As String _
) As String
[C#]
public string CleanString(
string str
);

Parameters

str
The string to be prepared for use in PostScript.

Return Value

Remarks

NOTE: All internal writing methods use this method to clean strings. You do not normally have to call this method in your code. If you were calling WriteRaw() then this utility method is useful.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DefineEmbeddedFont Method

Defines a non-resident font that will be used in the document with a path to a PFA font file.

[Visual Basic]
Public Sub DefineEmbeddedFont( _
ByVal PFAFilePath As String, _
ByVal commonName As String, _
ByVal officialName As String _
)
[C#]
public void DefineEmbeddedFont(
string PFAFilePath,
string commonName,
string officialName
);

Parameters

PFAFilePath
Absolute path and file name of a PFA font file.
commonName
The common short name you will use to call this font in your code.
officialName
The official name of the font taken from the /FontName entry in the PFA file.

Remarks

The official name of the font taken from the /FontName entry in the PFA file.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DefineEmbeddedFontCnt Method

Defines a non-resident font that will be used in the document. Uses the contents of a PFA font file directly.

[Visual Basic]
Public Sub DefineEmbeddedFontCnt( _
ByVal PFAFileContents As String, _
ByVal commonName As String, _
ByVal officialName As String _
)
[C#]
public void DefineEmbeddedFontCnt(
string PFAFileContents,
string commonName,
string officialName
);

Parameters

PFAFileContents
The raw contents of an PFA font file.
commonName
The common short name you will use to call this font in your code.
officialName
The official name of the font taken from the /FontName entry in the PFA file.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DefineFont Method

Defines a font that is installed onto the target PostScript device. (Resident font).

[Visual Basic]
Public Sub DefineFont( _
ByVal commonName As String, _
ByVal officialName As String _
)
[C#]
public void DefineFont(
string commonName,
string officialName
);

Parameters

commonName
The common short name you will use to call this font in your code.
officialName
The official name of the font taken from the /FontName entry in the PFA file.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DefinePieChart Method

Defines a pie chart structure that will be called for in the document.

[Visual Basic]
Public Sub DefinePieChart( _
ByVal pieChartDefinition As PieChart _
)
[C#]
public void DefinePieChart(
PieChart pieChartDefinition
);

Parameters

pieChartDefinition

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


DrawCircle Method

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.DrawCircle Method

Draws an unfilled circle onto the document.

Overload List

Draws an unfilled circle onto the document.

public void DrawCircle(PointS,float,float,PSColor);

Draws a filled circle on the document.

public void DrawCircle(PointS,float,float,PSColor,PSColor);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DrawCircle Method (PointS, Single, Single, PSColor)

Draws an unfilled circle onto the document.

[Visual Basic]
Overloads Public Sub DrawCircle( _
ByVal center As PointS, _
ByVal lineWidth As Single, _
ByVal radius As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawCircle(
PointS center,
float lineWidth,
float radius,
PSColor lineInkColor
);

Parameters

center
PointS object containing the location for the center of the circle.
lineWidth
The width of the line in points.
radius
The radius of the circle in points.
lineInkColor
PSColor object containing color information for the outline of the circle.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawCircle Overload List


PSDocument.DrawCircle Method (PointS, Single, Single, PSColor, PSColor)

Draws a filled circle on the document.

[Visual Basic]
Overloads Public Sub DrawCircle( _
ByVal center As PointS, _
ByVal lineWidth As Single, _
ByVal radius As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawCircle(
PointS center,
float lineWidth,
float radius,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

center
PointS object containing the location for the center of the circle.
lineWidth
The width of the line in points.
radius
The radius of the circle in points.
lineInkColor
PSColor object containing color information for the outline of the circle.
fillInkColor
PSColor object containing color information for the fill of the circle.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawCircle Overload List


PSDocument.DrawDashedLine Method

Draws a dashed line onto the document.

[Visual Basic]
Public Sub DrawDashedLine( _
ByVal startPoint As PointS, _
ByVal endPoint As PointS, _
ByVal lineWidth As Single, _
ByVal lineInk As PSColor, _
ByVal dashOn As Single, _
ByVal dashOff As Single, _
ByVal dashPhase As Single _
)
[C#]
public void DrawDashedLine(
PointS startPoint,
PointS endPoint,
float lineWidth,
PSColor lineInk,
float dashOn,
float dashOff,
float dashPhase
);

Parameters

startPoint
PointS object containing X and Y coordinates that define the starting location of the line.
endPoint
PointS object containing X and Y coordinates that define the ending location of the line.
lineWidth
The width of the line in points.
lineInk
PSColor object containing color information for the line.
dashOn
Number of units of ink in points.
dashOff
Number of units of no ink in points.
dashPhase
Repeat ink - no ink pattern every # of cycles.

Remarks

A dashed line is a number of units of ink followed by a number of units of no ink. Dash phase is 0 (no repeat) to any value (repeat pattern every # units).

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DrawPieChart Method

Causes a pie chart to be drawn on the document centered on the point identified by center.

[Visual Basic]
Public Sub DrawPieChart( _
ByVal center As PointS, _
ByVal slices As PieChartSlice(), _
ByVal chartRadius As Single, _
Optional ByVal suppressZeroPercentSlices As Boolean = False _
)
[C#]
public void DrawPieChart(
PointS center,
PieChartSlice[] slices,
float chartRadius,
bool suppressZeroPercentSlices
);

Parameters

center
PointS object containing the location to center the chart on.
slices
An array of slice structures. (Percentages should add up to 100.00)
chartRadius
The radius of the pie chart circle.
suppressZeroPercentSlices
If true then slices with a value of 0 of less will not be drawn.

Remarks

It is important that the percentage of the slices add up to 100.0 or the pie chart will not look 'even'. Also, the pie chart must have been previously defined by calling DefinePieChart() and passing in a definition structure.

See Also

PSDocument Class | PSWriteNetLib Namespace


DrawRdRectangle Method

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.DrawRdRectangle Method

Draws an unfilled rectangle with rounded corners.

Overload List

Draws an unfilled rectangle with rounded corners.

public void DrawRdRectangle(PointS,float,float,float,float,PSColor);

Draws a filled rectangle with rounded corners.

public void DrawRdRectangle(PointS,float,float,float,float,PSColor,PSColor);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DrawRdRectangle Method (PointS, Single, Single, Single, Single, PSColor)

Draws an unfilled rectangle with rounded corners.

[Visual Basic]
Overloads Public Sub DrawRdRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal cornerRadius As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawRdRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
float cornerRadius,
PSColor lineInkColor
);

Parameters

startPoint
PointS object containing the X and Y location of the lower left corner of the rectangle.
width
Width of the rectangle in points.
height
Height of the rectangle in points.
lineWidth
Width of the outline line in points.
cornerRadius
Radius of the corner arcs in points.
lineInkColor
PSColor object containing color information for the line.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawRdRectangle Overload List


PSDocument.DrawRdRectangle Method (PointS, Single, Single, Single, Single, PSColor, PSColor)

Draws a filled rectangle with rounded corners.

[Visual Basic]
Overloads Public Sub DrawRdRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal cornerRadius As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawRdRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
float cornerRadius,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

startPoint
PointS object containing the X and Y location of the lower left corner of the rectangle.
width
Width of the rectangle in points.
height
Height of the rectangle in points.
lineWidth
Width of the outline line in points.
cornerRadius
Radius of the corner arcs in points.
lineInkColor
PSColor object containing color information for the line.
fillInkColor
PSColor object containing color information for the fill.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawRdRectangle Overload List


DrawRectangle Method

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.DrawRectangle Method

Draw an unfilled rectangle onto the document.

Overload List

Draw an unfilled rectangle onto the document.

public void DrawRectangle(PointS,float,float,float,LineJoin,float,PSColor);

Draw a filled rectangle onto the document.

public void DrawRectangle(PointS,float,float,float,LineJoin,float,PSColor,PSColor);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.DrawRectangle Method (PointS, Single, Single, Single, LineJoin, Single, PSColor)

Draw an unfilled rectangle onto the document.

[Visual Basic]
Overloads Public Sub DrawRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal join As LineJoin, _
ByVal miterLimit As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
LineJoin join,
float miterLimit,
PSColor lineInkColor
);

Parameters

startPoint
PointS object containing the X and Y coordinates of the starting location for the rectangle.
width
The width of the rectangle in points.
height
The height of the rectangle in points.
lineWidth
The width of the outline line in points.
join
A value that determines the type of joint to make at corners.
miterLimit
The angle, in degrees, at which to cut off miter joints. 10 is normal.
lineInkColor
PSColor object to use for the outline color.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawRectangle Overload List


PSDocument.DrawRectangle Method (PointS, Single, Single, Single, LineJoin, Single, PSColor, PSColor)

Draw a filled rectangle onto the document.

[Visual Basic]
Overloads Public Sub DrawRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal join As LineJoin, _
ByVal miterLimit As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
LineJoin join,
float miterLimit,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

startPoint
PointS object containing the X and Y coordinates of the starting location for the rectangle.
width
The width of the rectangle in points.
height
The height of the rectangle in points.
lineWidth
The width of the outline line in points.
join
A value that determines the type of joint to make at corners.
miterLimit
The angle, in degrees, at which to cut off miter joints. 10 is normal.
lineInkColor
PSColor object to use for the outline color.
fillInkColor
PSColor object to use for the fill color.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.DrawRectangle Overload List


PSDocument.DrawSolidLine Method

Draws a solid line onto the document.

[Visual Basic]
Public Sub DrawSolidLine( _
ByVal startPoint As PointS, _
ByVal endPoint As PointS, _
ByVal lineWidth As Single, _
ByVal cap As LineCap, _
ByVal lineInk As PSColor _
)
[C#]
public void DrawSolidLine(
PointS startPoint,
PointS endPoint,
float lineWidth,
LineCap cap,
PSColor lineInk
);

Parameters

startPoint
PointS object containing X and Y coordinates for the starting location.
endPoint
PointS object containing X and Y coordinates for the ending location.
lineWidth
The width of the line in points.
cap
Value that determines how to draw the ends of lines.
lineInk
PSColor object containing color information for the line. Required.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.EndDoc Method

[Visual Basic]
Public Sub EndDoc()
[C#]
public void EndDoc();

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.EndPage Method

[Visual Basic]
Public Sub EndPage( _
Optional ByVal useRestore As Boolean = True _
)
[C#]
public void EndPage(
bool useRestore
);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.StartDoc Method

Initializes the library and begins the construction of a PostScript page description. Required call.

[Visual Basic]
Public Sub StartDoc( _
ByVal orient As DocumentOrientation, _
Optional ByVal usePJLInstructions As Boolean = False, _
Optional ByVal title As String = "PSWriteNetLib.PSDocument", _
Optional ByVal pageSize As PaperSize = 0, _
Optional ByVal paperSource As String = "Plain", _
Optional ByVal duplex As Boolean = False, _
Optional ByVal tumble As Boolean = False, _
Optional ByVal numCopies As Integer = 1, _
Optional ByVal targetDevice As String = "(Generic PostScript Device) (0) 0" _
)
[C#]
public void StartDoc(
DocumentOrientation orient,
bool usePJLInstructions,
string title,
PaperSize pageSize,
string paperSource,
bool duplex,
bool tumble,
int numCopies,
string targetDevice
);

Parameters

orient
Desired orientation of the page description.
usePJLInstructions
Bool to indicate whether the target device supports print language switching via PJL.
title
Internal title of the document. Not visible in document.
pageSize
Enum describing the standard media size of the page description.
paperSource
Free string describing the paper source on the target device.
duplex
Bool indicating whether printing on both sides of the media is desired.
tumble
Bool indicating whether back-side pages should print upside down, if duplex, for top bound documents.
numCopies
Number of copies of each page desired.
targetDevice
String describing the target PostScript device. For print managers.

Remarks

Calling startdoc is required. PostScript forms must be defined prior to calling startdoc.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.StartPage Method

Required call. Make this call when starting a new page in the document. Set useSave to true to save memory on the device.

[Visual Basic]
Public Sub StartPage( _
Optional ByVal useSave As Boolean = True, _
Optional ByVal orient As DocumentOrientation = 0 _
)
[C#]
public void StartPage(
bool useSave,
DocumentOrientation orient
);

Parameters

useSave
Set to true to save state. If you
orient

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteCommentLine Method

Writes a comment into the page description at the current file pointer location. Comments are ignored by all PostScript devices.

[Visual Basic]
Public Sub WriteCommentLine( _
ByVal strComment As String _
)
[C#]
public void WriteCommentLine(
string strComment
);

Parameters

strComment
The comment to be written to the document.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


WriteForm Method

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.WriteForm Method

Causes the specified PostScript form to be drawn at location 0,0 on the document. This is intended for full page forms. Use another overload to write a form at a specific location.

Overload List

Causes the specified PostScript form to be drawn at location 0,0 on the document. This is intended for full page forms. Use another overload to write a form at a specific location.

public void WriteForm(string);

Causes the specified PostScript form to be drawn at a specified location.

public void WriteForm(string,PointS);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteForm Method (String)

Causes the specified PostScript form to be drawn at location 0,0 on the document. This is intended for full page forms. Use another overload to write a form at a specific location.

[Visual Basic]
Overloads Public Sub WriteForm( _
ByVal formName As String _
)
[C#]
public void WriteForm(
string formName
);

Parameters

formName
The common name of the form to write.

Remarks

X and Y location information defined in the form is relative to the form and does not apply to the rest of the document.

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteForm Overload List


PSDocument.WriteForm Method (String, PointS)

Causes the specified PostScript form to be drawn at a specified location.

[Visual Basic]
Overloads Public Sub WriteForm( _
ByVal formName As String, _
ByVal formLocation As PointS _
)
[C#]
public void WriteForm(
string formName,
PointS formLocation
);

Parameters

formName
Common name of a previously defined PSForm object to draw.
formLocation
PointS object containing X and Y coordinates for the origin of the form.

Remarks

Default PostScript point of origin is 0,0. The lower left corner of the document.

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteForm Overload List


PSDocument.WriteImage Method

Writes a PSImage object to the document at a specified location.

[Visual Basic]
Public Sub WriteImage( _
ByVal img As PSImage, _
ByVal location As PointS _
)
[C#]
public void WriteImage(
PSImage img,
PointS location
);

Parameters

img
PSImage object to draw on the document.
location
PointS object containing X and Y coordinates to place the image.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteParagraph Method

Writes a paragraph to the document automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.

[Visual Basic]
Public Sub WriteParagraph( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal lineLen As Single, _
ByVal lineHeight As Single, _
ByVal commonFontName As String, _
ByVal fontSz As Single _
)
[C#]
public void WriteParagraph(
float xPos,
float yPos,
string str,
float lineLen,
float lineHeight,
string commonFontName,
float fontSz
);

Parameters

xPos
Horizontal position to begin the paragraph in points.
yPos
Vertical position to begin the paragraph in points.
str
The text to write as a paragraph.
lineLen
The max length of each line in points.
lineHeight
The spacing between lines in the paragraph in point.
commonFontName
The common font name of the font to use.
fontSz
The size of the font to use.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WritePostNetBarCode Method

Draws a PostNet bar code onto the document at the location specied.

[Visual Basic]
Public Sub WritePostNetBarCode( _
ByVal location As PointS, _
ByVal fontSz As Single, _
ByVal value As String _
)
[C#]
public void WritePostNetBarCode(
PointS location,
float fontSz,
string value
);

Parameters

location
PointS object containing X and Y coordinates for the start of the barcode string.
fontSz
Size of the font to use in points.
value
The 12 digit USPS barcode value.

Remarks

PostNet barcodes contain the zip and zip4, house number, delivery point number and a check digit. PSWriteNetLib cannot verify this information for you. If not correct the post office will charge additional money for delivery.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteRaw Method

Writes a single line of raw PostScript code into the output file at the current file position.

[Visual Basic]
Public Sub WriteRaw( _
ByVal psCode As String _
)
[C#]
public void WriteRaw(
string psCode
);

Parameters

psCode
Raw postscript code to write to the current page.

Remarks

No validity checking is performed. Invalid PostScript code will cause the PostScript device, printer or rasterizer(viewer), to error.

See Also

PSDocument Class | PSWriteNetLib Namespace


WriteString Method

PSWriteNetLib For CLR 1.1 Documentation

PSDocument.WriteString Method

Writes text onto the document. Does not change font size or font name.

Overload List

Writes text onto the document. Does not change font size or font name.

public void WriteString(float,float,string);

Writes text onto the document. Specifies font name and a transform matrix that can be used to manipulate the font in user space.

public void WriteString(float,float,string,TMatrix,string);

Writes text onto the document. Specifies font name and size.

public void WriteString(float,float,string,float,string);

Draws a string of text onto the document. Allows changing the character spacing in X and Y axis's and specifies a common font name and size.

public void WriteString(float,float,string,float,string,float,float);

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteString Method (Single, Single, String)

Writes text onto the document. Does not change font size or font name.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
The string of text to draw.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteString Overload List


PSDocument.WriteString Method (Single, Single, String, TMatrix, String)

Writes text onto the document. Specifies font name and a transform matrix that can be used to manipulate the font in user space.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal matrix As TMatrix, _
ByVal commonFontName As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
TMatrix matrix,
string commonFontName
);

Parameters

xPos
The horizonal location of text in points.
yPos
The vertical location of text in points.
str
The string of text to draw.
matrix
A transform matrix that allows font scaling, rotating and translating(moving).
commonFontName
The common name of the font to use.

Remarks

Use this overload to change the current font.

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteString Overload List


PSDocument.WriteString Method (Single, Single, String, Single, String)

Writes text onto the document. Specifies font name and size.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
The horizonal location of text in points.
yPos
The vertical location of text in points.
str
The string of text to draw.
fontSz
The font size to use in points.
commonFontName
The common name of the font to use.

Remarks

Use this overload to change the current font.

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteString Overload List


PSDocument.WriteString Method (Single, Single, String, Single, String, Single, Single)

Draws a string of text onto the document. Allows changing the character spacing in X and Y axis's and specifies a common font name and size.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String, _
ByVal addXSpacing As Single, _
ByVal addYSpacing As Single _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName,
float addXSpacing,
float addYSpacing
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
The string of text to draw.
fontSz
The size of the font to use in points.
commonFontName
The common name of the font to use.
addXSpacing
Additional horizontal spacing to add to all characters in points.
addYSpacing
Additional vertical spacing to all to all characters in points.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace | PSDocument.WriteString Overload List


PSDocument.WriteStringCN Method

Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.

[Visual Basic]
Public Function WriteStringCN( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
) As Boolean
[C#]
public bool WriteStringCN(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal position of center of string.
yPos
Vertical position of center of string.
str
Text to be written to the document.
fontSz
Size of the font to use
commonFontName
Common name of the font to use.

Return Value

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteStringRJ Method

Writes text to the document right-justified. Specifies font name and size.

[Visual Basic]
Public Sub WriteStringRJ( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteStringRJ(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal position to start writing the string.
yPos
Vertical position to start writing the string.
str
The string to write.
fontSz
The size of the font to use in points.
commonFontName
The common name of the font to use.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.WriteStringUL Method

Writes underlined text onto the document. Specifies font name and size

[Visual Basic]
Public Sub WriteStringUL( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteStringUL(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
String of text to draw.
fontSz
Font size to use in points.
commonFontName
Common font name to use.

Remarks

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument Events

The events of the PSDocument class are listed below. For a complete list of PSDocument class members, see the PSDocument Members topic.

Public Instance Events

Document_Complete
NewPage_Created

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.Document_Complete Event

[Visual Basic]
Public Event Document_Complete As Document_CompleteEventHandler
[C#]
public event Document_CompleteEventHandler Document_Complete;

Event Data

The event handler receives an argument of type DocumentCompleteEventArgs containing data related to this event. The following DocumentCompleteEventArgs property provides information specific to this event.

Property | Description
PageCount | Gets the number of pages in the document.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.NewPage_Created Event

[Visual Basic]
Public Event NewPage_Created As NewPage_CreatedEventHandler
[C#]
public event NewPage_CreatedEventHandler NewPage_Created;

Event Data

The event handler receives an argument of type PageCreatedEventArgs containing data related to this event. The following PageCreatedEventArgs property provides information specific to this event.

Property | Description
CurrentPageNumber | Gets the page number of the new page in the document.

See Also

PSDocument Class | PSWriteNetLib Namespace


PSDocument.Document_CompleteEventHandler Delegate

[Visual Basic]
Public Delegate Sub PSDocument.Document_CompleteEventHandler( _
ByVal sender As Object, _
ByVal e As DocumentCompleteEventArgs _
)
[C#]
public delegate void PSDocument.Document_CompleteEventHandler(
object sender,
DocumentCompleteEventArgs e
);

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.DocumentOrientation Enumeration

Value that determines the normal orientation of this page description.

[Visual Basic]
Public Enum PSDocument.DocumentOrientation
[C#]
public enum PSDocument.DocumentOrientation

Remarks

Members

Member Name | Description
Portrait |
Landscape |

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.LineCap Enumeration

Value that determines how to draw the ends of lines.

[Visual Basic]
Public Enum PSDocument.LineCap
[C#]
public enum PSDocument.LineCap

Remarks

Members

Member Name | Description
Butt |
Round |
ProjectingSquare |

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.LineJoin Enumeration

Value that determines the kind of joints to make between lines.

[Visual Basic]
Public Enum PSDocument.LineJoin
[C#]
public enum PSDocument.LineJoin

Remarks

Members

Member Name | Description
Miter |
Round |
Bevel |

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.NewPage_CreatedEventHandler Delegate

[Visual Basic]
Public Delegate Sub PSDocument.NewPage_CreatedEventHandler( _
ByVal sender As Object, _
ByVal e As PageCreatedEventArgs _
)
[C#]
public delegate void PSDocument.NewPage_CreatedEventHandler(
object sender,
PageCreatedEventArgs e
);

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.PaperSize Enumeration

Value that indicates the standard paper size for this page description.

[Visual Basic]
Public Enum PSDocument.PaperSize
[C#]
public enum PSDocument.PaperSize

Remarks

Members

Member Name | Description
Letter |
Legal |
Tabloid |
A4 |
A3 |
mm223x297mm |
NinexEleven |
B4 |
EightPointFivex13 |
ISOB4 |

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSWriteNetLib Namespace


PSDocument.PieChart Structure

Structure that defines a pie chart.

For a list of all members of this type, see PSDocument.PieChart Members.

System.Object
System.ValueType
PSWriteNetLib.PSDocument.PieChart

[Visual Basic]
Public Structure PSDocument.PieChart
[C#]
public struct PSDocument.PieChart

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSDocument.PieChart Members | PSWriteNetLib Namespace


PSDocument.PieChart Members

PSDocument.PieChart overview

Public Instance Fields

LabelFontName
LabelFontSz
Title
TitleFontName
TitleFontSz

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart Fields

The fields of the PSDocument.PieChart structure are listed below. For a complete list of PSDocument.PieChart structure members, see the PSDocument.PieChart Members topic.

Public Instance Fields

LabelFontName
LabelFontSz
Title
TitleFontName
TitleFontSz

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart.LabelFontName Field

[Visual Basic]
Public LabelFontName As String
[C#]
public string LabelFontName;

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart.LabelFontSz Field

[Visual Basic]
Public LabelFontSz As Short
[C#]
public short LabelFontSz;

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart.Title Field

[Visual Basic]
Public Title As String
[C#]
public string Title;

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart.TitleFontName Field

[Visual Basic]
Public TitleFontName As String
[C#]
public string TitleFontName;

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChart.TitleFontSz Field

[Visual Basic]
Public TitleFontSz As Short
[C#]
public short TitleFontSz;

See Also

PSDocument.PieChart Class | PSWriteNetLib Namespace


PSDocument.PieChartSlice Structure

Structure that defines a single slice of a pie chart.

For a list of all members of this type, see PSDocument.PieChartSlice Members.

System.Object
System.ValueType
PSWriteNetLib.PSDocument.PieChartSlice

[Visual Basic]
Public Structure PSDocument.PieChartSlice
[C#]
public struct PSDocument.PieChartSlice

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSDocument.PieChartSlice Members | PSWriteNetLib Namespace


PSDocument.PieChartSlice Members

PSDocument.PieChartSlice overview

Public Instance Fields

Label
Percentage

Public Instance Methods

Equals (inherited from ValueType) | Indicates whether this instance and a specified object are equal.
GetHashCode (inherited from ValueType) | Returns the hash code for this instance.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from ValueType) | Returns the fully qualified type name of this instance.

See Also

PSDocument.PieChartSlice Class | PSWriteNetLib Namespace


PSDocument.PieChartSlice Fields

The fields of the PSDocument.PieChartSlice structure are listed below. For a complete list of PSDocument.PieChartSlice structure members, see the PSDocument.PieChartSlice Members topic.

Public Instance Fields

Label
Percentage

See Also

PSDocument.PieChartSlice Class | PSWriteNetLib Namespace


PSDocument.PieChartSlice.Label Field

[Visual Basic]
Public Label As String
[C#]
public string Label;

See Also

PSDocument.PieChartSlice Class | PSWriteNetLib Namespace


PSDocument.PieChartSlice.Percentage Field

[Visual Basic]
Public Percentage As Double
[C#]
public double Percentage;

See Also

PSDocument.PieChartSlice Class | PSWriteNetLib Namespace


PSForm Class

Provides a cached form object that is only written once to the underlying PostScript file and can be called unlimited times. Saves memory and reduces output file size.

For a list of all members of this type, see PSForm Members.

System.Object
PSWriteNetLib.PSFormBase
PSWriteNetLib.PSForm

[Visual Basic]
Public Class PSForm
Inherits PSFormBase
[C#]
public class PSForm : PSFormBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

There are 3 ways to use forms. You can write the raw postscript yourself into a string array and pass it to the PaintProcCode property. Or you can call the writing and drawing methods on the form itself after creating it but before calling startdoc(). You can also pass in an EPS file name to use the EPS file as the form. EPS files can contain images and text and any valid PostScipt code. If you pass an EPS file name then you must also pass in a bounding box whose values are the same as the %%BoundingBox comment line in the EPS file.

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSForm Members | PSWriteNetLib Namespace


PSForm Members

PSForm overview

Public Instance Constructors

PSForm Overloaded. Initializes a new instance of the PSForm class.

Public Instance Properties

BBox | Gets the bounding box of this form. Specifies the size of the form.
EmbeddedEPSFileName | Gets the absolute path and file name of an EPS file to display in the form.
EPSDataString | Gets or sets a string of EPS data from an EPS file. You can read in all the lines from an EPS file here and use this form to display it.
FormName | Gets the name of this form to use when calling WriteForm().
ID | Gets a string that uniquely identifies this instance.
PaintProcCode | Sets or gets a string array that contains all the PostScript code needed to draw the form onto a document. Can include procedures and any valid postscript code.
TransformationMatrix | Gets or sets the transformation matrix for this form. Transformations are performed on the forms user space, not the documents user space.

Public Instance Methods

ChangeInk | Changes the color of ink in the current graphics object of this form.
DrawCircle | Overloaded. Draws an unfilled circle onto the form.
DrawDashedLine | Draws a dashed line onto the form.
DrawRdRectangle | Overloaded. Draws a filled rectangle with rounded corners.
DrawRectangle | Overloaded. Draw an unfilled rectangle onto the form.
DrawSolidLine | Draws a solid line onto the form.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAllDrawingInstructions | Removes all drawing instructions from the internal form buffer. Cannot be undone.
ScaleForm | Scales the form and all its contents to the values specified here.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteImage | Writes a PSImage object to the form at a specified location.
WriteParagraph | Writes a paragraph to the form automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.
WritePostNetBarCode |
WriteRaw | Writes a single line of raw PostScript code into this form.
WriteString | Overloaded. Writes text onto the document. Does not change font size or font name.
WriteStringCN | Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.
WriteStringRJ | Writes text to the document right-justified. Specifies font name and size.
WriteStringUL | Writes underlined text onto the form. Specifies font name and size

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm Constructor

Gets a new form object with its common name and bounding box set.

Overload List

Gets a new form object with its common name and bounding box set.

public PSForm(PSDocument,string,BoundingBox);

Gets a new form object that will display the contents of an EPS file.

public PSForm(PSDocument,string,string,BoundingBox);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm Constructor (PSDocument, String, BoundingBox)

Gets a new form object with its common name and bounding box set.

[Visual Basic]
Overloads Public Sub New( _
ByVal parent As PSDocument, _
ByVal formName As String, _
ByVal bx As BoundingBox _
)
[C#]
public PSForm(
PSDocument parent,
string formName,
BoundingBox bx
);

Parameters

parent
PSDocument object that owns this form.
formName
The common name of this form. You will use this name when calling WriteForm().
bx
A bounding box object specifing the bounding box for the form.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm Constructor Overload List


PSForm Constructor (PSDocument, String, String, BoundingBox)

Gets a new form object that will display the contents of an EPS file.

[Visual Basic]
Overloads Public Sub New( _
ByVal parent As PSDocument, _
ByVal formName As String, _
ByVal EPSFilePathAndName As String, _
ByVal bx As BoundingBox _
)
[C#]
public PSForm(
PSDocument parent,
string formName,
string EPSFilePathAndName,
BoundingBox bx
);

Parameters

parent
PSDocument object that owns this form.
formName
The common name of this form. You will use this name when calling WriteForm().
EPSFilePathAndName
File path and name of an EPS file to display in the form.
bx
A bounding box object whose values are identical to those specified in the EPS file.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm Constructor Overload List


PSForm Properties

The properties of the PSForm class are listed below. For a complete list of PSForm class members, see the PSForm Members topic.

Public Instance Properties

BBox | Gets the bounding box of this form. Specifies the size of the form.
EmbeddedEPSFileName | Gets the absolute path and file name of an EPS file to display in the form.
EPSDataString | Gets or sets a string of EPS data from an EPS file. You can read in all the lines from an EPS file here and use this form to display it.
FormName | Gets the name of this form to use when calling WriteForm().
ID | Gets a string that uniquely identifies this instance.
PaintProcCode | Sets or gets a string array that contains all the PostScript code needed to draw the form onto a document. Can include procedures and any valid postscript code.
TransformationMatrix | Gets or sets the transformation matrix for this form. Transformations are performed on the forms user space, not the documents user space.

See Also

PSForm Class | PSWriteNetLib Namespace


BBox Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.BBox Property

Gets the bounding box of this form. Specifies the size of the form.

[Visual Basic]
Public ReadOnly Property BBox As BoundingBox
[C#]
public BoundingBox BBox {get;}

Property Value

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


EmbeddedEPSFileName Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.EmbeddedEPSFileName Property

Gets the absolute path and file name of an EPS file to display in the form.

[Visual Basic]
Public ReadOnly Property EmbeddedEPSFileName As String
[C#]
public string EmbeddedEPSFileName {get;}

Property Value

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


EPSDataString Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.EPSDataString Property

Gets or sets a string of EPS data from an EPS file. You can read in all the lines from an EPS file here and use this form to display it.

[Visual Basic]
Public Property EPSDataString As String
[C#]
public string EPSDataString {get; set;}

Property Value

Remarks

You must set a bounding box object in the BBox property with the same values as those in the EPS file. Only 1 EPS file allowed per form.

See Also

PSForm Class | PSWriteNetLib Namespace


FormName Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.FormName Property

Gets the name of this form to use when calling WriteForm().

[Visual Basic]
Public ReadOnly Property FormName As String
[C#]
public string FormName {get;}

Property Value

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


ID Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.ID Property

Gets a string that uniquely identifies this instance.

[Visual Basic]
Public ReadOnly Property ID As String
[C#]
public string ID {get;}

Property Value

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PaintProcCode Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.PaintProcCode Property

Sets or gets a string array that contains all the PostScript code needed to draw the form onto a document. Can include procedures and any valid postscript code.

[Visual Basic]
Public Property PaintProcCode As String()
[C#]
public string[] PaintProcCode {get; set;}

Property Value

Remarks

One line of code per slot in the array. If there is a EPS file set in this object then this paint code will not be run.

See Also

PSForm Class | PSWriteNetLib Namespace


TransformationMatrix Property

PSWriteNetLib For CLR 1.1 Documentation

PSForm.TransformationMatrix Property

Gets or sets the transformation matrix for this form. Transformations are performed on the forms user space, not the documents user space.

[Visual Basic]
Public Property TransformationMatrix As TMatrix
[C#]
public TMatrix TransformationMatrix {get; set;}

Property Value

Remarks

You can manipulate the user space of the form. You can translate(move the point of origin) of the form. Scale the forms contents or rotate the forms contents about its point of origin.

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm Methods

The methods of the PSForm class are listed below. For a complete list of PSForm class members, see the PSForm Members topic.

Public Instance Methods

ChangeInk | Changes the color of ink in the current graphics object of this form.
DrawCircle | Overloaded. Draws an unfilled circle onto the form.
DrawDashedLine | Draws a dashed line onto the form.
DrawRdRectangle | Overloaded. Draws a filled rectangle with rounded corners.
DrawRectangle | Overloaded. Draw an unfilled rectangle onto the form.
DrawSolidLine | Draws a solid line onto the form.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveAllDrawingInstructions | Removes all drawing instructions from the internal form buffer. Cannot be undone.
ScaleForm | Scales the form and all its contents to the values specified here.
ToString (inherited from Object) | Returns a String that represents the current Object.
WriteImage | Writes a PSImage object to the form at a specified location.
WriteParagraph | Writes a paragraph to the form automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.
WritePostNetBarCode |
WriteRaw | Writes a single line of raw PostScript code into this form.
WriteString | Overloaded. Writes text onto the document. Does not change font size or font name.
WriteStringCN | Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.
WriteStringRJ | Writes text to the document right-justified. Specifies font name and size.
WriteStringUL | Writes underlined text onto the form. Specifies font name and size

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.ChangeInk Method

Changes the color of ink in the current graphics object of this form.

[Visual Basic]
Public Function ChangeInk( _
ByVal newInk As PSColor _
) As Boolean
[C#]
public bool ChangeInk(
PSColor newInk
);

Parameters

newInk
PSColor object containing color information.

Return Value

Remarks

Changing ink color is meaningful only for text operations. Drawing operations require PSColor parameters and are separate from graphics drawing operations.

See Also

PSForm Class | PSWriteNetLib Namespace


DrawCircle Method

PSWriteNetLib For CLR 1.1 Documentation

PSForm.DrawCircle Method

Draws an unfilled circle onto the form.

Overload List

Draws an unfilled circle onto the form.

public void DrawCircle(PointS,float,float,PSColor);

Draws a filled circle on the form.

public void DrawCircle(PointS,float,float,PSColor,PSColor);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.DrawCircle Method (PointS, Single, Single, PSColor)

Draws an unfilled circle onto the form.

[Visual Basic]
Overloads Public Sub DrawCircle( _
ByVal center As PointS, _
ByVal lineWidth As Single, _
ByVal radius As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawCircle(
PointS center,
float lineWidth,
float radius,
PSColor lineInkColor
);

Parameters

center
PointS object containing the location for the center of the circle.
lineWidth
The width of the line in points.
radius
The radius of the circle in points.
lineInkColor
PSColor object containing color information for the outline of the circle.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawCircle Overload List


PSForm.DrawCircle Method (PointS, Single, Single, PSColor, PSColor)

Draws a filled circle on the form.

[Visual Basic]
Overloads Public Sub DrawCircle( _
ByVal center As PointS, _
ByVal lineWidth As Single, _
ByVal radius As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawCircle(
PointS center,
float lineWidth,
float radius,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

center
PointS object containing the location for the center of the circle.
lineWidth
The width of the line in points.
radius
The radius of the circle in points.
lineInkColor
PSColor object containing color information for the outline of the circle.
fillInkColor
PSColor object containing color information for the fill of the circle.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawCircle Overload List


PSForm.DrawDashedLine Method

Draws a dashed line onto the form.

[Visual Basic]
Public Sub DrawDashedLine( _
ByVal startPoint As PointS, _
ByVal endPoint As PointS, _
ByVal lineWidth As Single, _
ByVal lineInk As PSColor, _
ByVal dashOn As Single, _
ByVal dashOff As Single, _
ByVal dashPhase As Single _
)
[C#]
public void DrawDashedLine(
PointS startPoint,
PointS endPoint,
float lineWidth,
PSColor lineInk,
float dashOn,
float dashOff,
float dashPhase
);

Parameters

startPoint
PointS object containing X and Y coordinates that define the starting location of the line.
endPoint
PointS object containing X and Y coordinates that define the ending location of the line.
lineWidth
The width of the line in points.
lineInk
PSColor object containing color information for the line.
dashOn
Number of units of ink in points.
dashOff
Number of units of no ink in points.
dashPhase
Repeat ink - no ink pattern every # of cycles.

Remarks

A dashed line is a number of units of ink followed by a number of units of no ink. Dash phase is 0 (no repeat) to any value (repeat pattern every # units).

See Also

PSForm Class | PSWriteNetLib Namespace


DrawRdRectangle Method

PSWriteNetLib For CLR 1.1 Documentation

PSForm.DrawRdRectangle Method

Draws an unfilled rectangle with rounded corners.

Overload List

Draws an unfilled rectangle with rounded corners.

public void DrawRdRectangle(PointS,float,float,float,float,PSColor);

Draws a filled rectangle with rounded corners.

public void DrawRdRectangle(PointS,float,float,float,float,PSColor,PSColor);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.DrawRdRectangle Method (PointS, Single, Single, Single, Single, PSColor)

Draws an unfilled rectangle with rounded corners.

[Visual Basic]
Overloads Public Sub DrawRdRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal cornerRadius As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawRdRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
float cornerRadius,
PSColor lineInkColor
);

Parameters

startPoint
PointS object containing the X and Y location of the lower left corner of the rectangle.
width
Width of the rectangle in points.
height
Height of the rectangle in points.
lineWidth
Width of the outline line in points.
cornerRadius
Radius of the corner arcs in points.
lineInkColor
PSColor object containing color information for the line.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawRdRectangle Overload List


PSForm.DrawRdRectangle Method (PointS, Single, Single, Single, Single, PSColor, PSColor)

Draws a filled rectangle with rounded corners.

[Visual Basic]
Overloads Public Sub DrawRdRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal cornerRadius As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawRdRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
float cornerRadius,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

startPoint
PointS object containing the X and Y location of the lower left corner of the rectangle.
width
Width of the rectangle in points.
height
Height of the rectangle in points.
lineWidth
Width of the outline line in points.
cornerRadius
Radius of the corner arcs in points.
lineInkColor
PSColor object containing color information for the line.
fillInkColor
PSColor object containing color information for the fill.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawRdRectangle Overload List


DrawRectangle Method

PSWriteNetLib For CLR 1.1 Documentation

PSForm.DrawRectangle Method

Draw an unfilled rectangle onto the form.

Overload List

Draw an unfilled rectangle onto the form.

public void DrawRectangle(PointS,float,float,float,LineJoin,float,PSColor);

Draw a filled rectangle onto the form.

public void DrawRectangle(PointS,float,float,float,LineJoin,float,PSColor,PSColor);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.DrawRectangle Method (PointS, Single, Single, Single, LineJoin, Single, PSColor)

Draw an unfilled rectangle onto the form.

[Visual Basic]
Overloads Public Sub DrawRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal join As LineJoin, _
ByVal miterLimit As Single, _
ByVal lineInkColor As PSColor _
)
[C#]
public void DrawRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
LineJoin join,
float miterLimit,
PSColor lineInkColor
);

Parameters

startPoint
PointS object containing the X and Y coordinates of the starting location for the rectangle.
width
The width of the rectangle in points.
height
The height of the rectangle in points.
lineWidth
The width of the outline line in points.
join
A value that determines the type of joint to make at corners.
miterLimit
The angle, in degrees, at which to cut off miter joints. 10 is normal.
lineInkColor
PSColor object to use for the outline color.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawRectangle Overload List


PSForm.DrawRectangle Method (PointS, Single, Single, Single, LineJoin, Single, PSColor, PSColor)

Draw a filled rectangle onto the form.

[Visual Basic]
Overloads Public Sub DrawRectangle( _
ByVal startPoint As PointS, _
ByVal width As Single, _
ByVal height As Single, _
ByVal lineWidth As Single, _
ByVal join As LineJoin, _
ByVal miterLimit As Single, _
ByVal lineInkColor As PSColor, _
ByVal fillInkColor As PSColor _
)
[C#]
public void DrawRectangle(
PointS startPoint,
float width,
float height,
float lineWidth,
LineJoin join,
float miterLimit,
PSColor lineInkColor,
PSColor fillInkColor
);

Parameters

startPoint
PointS object containing the X and Y coordinates of the starting location for the rectangle.
width
The width of the rectangle in points.
height
The height of the rectangle in points.
lineWidth
The width of the outline line in points.
join
A value that determines the type of joint to make at corners.
miterLimit
The angle, in degrees, at which to cut off miter joints. 10 is normal.
lineInkColor
PSColor object to use for the outline color.
fillInkColor
PSColor object to use for the fill color.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.DrawRectangle Overload List


PSForm.DrawSolidLine Method

Draws a solid line onto the form.

[Visual Basic]
Public Sub DrawSolidLine( _
ByVal startPoint As PointS, _
ByVal endPoint As PointS, _
ByVal lineWidth As Single, _
ByVal cap As LineCap, _
ByVal lineInk As PSColor _
)
[C#]
public void DrawSolidLine(
PointS startPoint,
PointS endPoint,
float lineWidth,
LineCap cap,
PSColor lineInk
);

Parameters

startPoint
PointS object containing X and Y coordinates for the starting location.
endPoint
PointS object containing X and Y coordinates for the ending location.
lineWidth
The width of the line in points.
cap
Value that determines how to draw the ends of lines.
lineInk
PSColor object containing color information for the line. Required.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.RemoveAllDrawingInstructions Method

Removes all drawing instructions from the internal form buffer. Cannot be undone.

[Visual Basic]
Public Sub RemoveAllDrawingInstructions()
[C#]
public void RemoveAllDrawingInstructions();

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.ScaleForm Method

Scales the form and all its contents to the values specified here.

[Visual Basic]
Public Sub ScaleForm( _
ByVal width As Single, _
ByVal height As Single _
)
[C#]
public void ScaleForm(
float width,
float height
);

Parameters

width
Desired width of the form in points.
height
Desired height of the form in points.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteImage Method

Writes a PSImage object to the form at a specified location.

[Visual Basic]
Public Sub WriteImage( _
ByVal img As PSImage, _
ByVal location As PointS _
)
[C#]
public void WriteImage(
PSImage img,
PointS location
);

Parameters

img
PSImage object to draw on the form.
location
PointS object containing X and Y coordinates to place the image relative to the form.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteParagraph Method

Writes a paragraph to the form automatically wrapping lines. Specifies font name, font size, line width, line height and a string of text.

[Visual Basic]
Public Sub WriteParagraph( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal lineLen As Single, _
ByVal lineHeight As Single, _
ByVal commonFontName As String, _
ByVal fontSz As Single _
)
[C#]
public void WriteParagraph(
float xPos,
float yPos,
string str,
float lineLen,
float lineHeight,
string commonFontName,
float fontSz
);

Parameters

xPos
Horizontal position to begin the paragraph in points.
yPos
Vertical position to begin the paragraph in points.
str
The text to write as a paragraph.
lineLen
The max length of each line in points.
lineHeight
The spacing between lines in the paragraph in point.
commonFontName
The common font name of the font to use.
fontSz
The size of the font to use.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WritePostNetBarCode Method

[Visual Basic]
Public Sub WritePostNetBarCode( _
ByVal location As PointS, _
ByVal fontPTSize As Single, _
ByVal value As String _
)
[C#]
public void WritePostNetBarCode(
PointS location,
float fontPTSize,
string value
);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteRaw Method

Writes a single line of raw PostScript code into this form.

[Visual Basic]
Public Sub WriteRaw( _
ByVal psCode As String _
)
[C#]
public void WriteRaw(
string psCode
);

Parameters

psCode
Raw postscript code to write to the current page.

Remarks

No validity checking is performed. Invalid PostScript code will cause the PostScript device, printer or rasterizer(viewer), to error.

See Also

PSForm Class | PSWriteNetLib Namespace


WriteString Method

PSWriteNetLib For CLR 1.1 Documentation

PSForm.WriteString Method

Writes text onto the document. Does not change font size or font name.

Overload List

Writes text onto the document. Does not change font size or font name.

public void WriteString(float,float,string);

Writes text onto the form. Specifies font name and a transform matrix that can be used to manipulate the font in user space.

public void WriteString(float,float,string,TMatrix,string);

Writes text onto the document. Specifies font name and size.

public void WriteString(float,float,string,float,string);

Draws a string of text onto the document. Allows changing the character spacing in X and Y axis's and specifies a common font name and size.

public void WriteString(float,float,string,float,string,float,float);

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteString Method (Single, Single, String)

Writes text onto the document. Does not change font size or font name.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
The string of text to draw.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.WriteString Overload List


PSForm.WriteString Method (Single, Single, String, TMatrix, String)

Writes text onto the form. Specifies font name and a transform matrix that can be used to manipulate the font in user space.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal matrix As TMatrix, _
ByVal commonFontName As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
TMatrix matrix,
string commonFontName
);

Parameters

xPos
The horizonal location of text in points.
yPos
The vertical location of text in points.
str
The string of text to draw.
matrix
A transform matrix that allows font scaling, rotating and translating(moving).
commonFontName
The common name of the font to use.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.WriteString Overload List


PSForm.WriteString Method (Single, Single, String, Single, String)

Writes text onto the document. Specifies font name and size.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
The horizonal location of text in points.
yPos
The vertical location of text in points.
str
The string of text to draw.
fontSz
The font size to use in points.
commonFontName
The common name of the font to use.

Remarks

Use this overload to change the current font.

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.WriteString Overload List


PSForm.WriteString Method (Single, Single, String, Single, String, Single, Single)

Draws a string of text onto the document. Allows changing the character spacing in X and Y axis's and specifies a common font name and size.

[Visual Basic]
Overloads Public Sub WriteString( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String, _
ByVal addXSpacing As Single, _
ByVal addYSpacing As Single _
)
[C#]
public void WriteString(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName,
float addXSpacing,
float addYSpacing
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
The string of text to draw.
fontSz
The size of the font to use in points.
commonFontName
The common name of the font to use.
addXSpacing
Additional horizontal spacing to add to all characters in points.
addYSpacing
Additional vertical spacing to all to all characters in points.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace | PSForm.WriteString Overload List


PSForm.WriteStringCN Method

Centers a string of text on a point specified by xPos and yPos. Specifies font name and size.

[Visual Basic]
Public Sub WriteStringCN( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteStringCN(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal position of center of string.
yPos
Vertical position of center of string.
str
Text to be written to the document.
fontSz
Size of the font to use
commonFontName
Common name of the font to use.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteStringRJ Method

Writes text to the document right-justified. Specifies font name and size.

[Visual Basic]
Public Sub WriteStringRJ( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteStringRJ(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal position to start writing the string.
yPos
Vertical position to start writing the string.
str
The string to write.
fontSz
The size of the font to use in points.
commonFontName
The common name of the font to use.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSForm.WriteStringUL Method

Writes underlined text onto the form. Specifies font name and size

[Visual Basic]
Public Sub WriteStringUL( _
ByVal xPos As Single, _
ByVal yPos As Single, _
ByVal str As String, _
ByVal fontSz As Single, _
ByVal commonFontName As String _
)
[C#]
public void WriteStringUL(
float xPos,
float yPos,
string str,
float fontSz,
string commonFontName
);

Parameters

xPos
Horizontal location of text in points.
yPos
Vertical location of text in points.
str
String of text to draw.
fontSz
Font size to use in points.
commonFontName
Common font name to use.

Remarks

See Also

PSForm Class | PSWriteNetLib Namespace


PSFormBase Class

Provides a core object used by PSWriteLib. Not intended to by used directly from your code.

For a list of all members of this type, see PSFormBase Members.

System.Object
PSWriteNetLib.PSFormBase
PSWriteNetLib.PSForm

[Visual Basic]
MustInherit Public Class PSFormBase
[C#]
public abstract class PSFormBase

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSFormBase Members | PSWriteNetLib Namespace


PSFormBase Members

PSFormBase overview

Public Instance Constructors

PSFormBase Constructor Initializes a new instance of the PSFormBase class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PSFormBase Class | PSWriteNetLib Namespace


PSFormBase Constructor

Initializes a new instance of the PSFormBase class.

[Visual Basic]
Public Sub New()
[C#]
public PSFormBase();

See Also

PSFormBase Class | PSWriteNetLib Namespace


PSImage Class

Provides a class that encapsulates an image that can be drawn into a PSDocument or into a PSForm object.

For a list of all members of this type, see PSImage Members.

System.Object
PSWriteNetLib.PSImage

[Visual Basic]
Public Class PSImage
[C#]
public class PSImage

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Image types supported are: bmp, jpg, png and gif. Images must be RBG, not grayscale or byte bit black and white.

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

PSImage Members | PSWriteNetLib Namespace


PSImage Members

PSImage overview

Public Static (Shared) Methods

CreateHexAsciiImageFile | Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.
GetHexAsciiData | Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.

Public Instance Constructors

PSImage Overloaded. Initializes a new instance of the PSImage class.

Public Instance Properties

DecodeMatrix | Gets or sets the transformation matrix to use for decoding this image. Normally you will not have to change this object.
Height | Gets or sets the actual height of this image in pixels.
Image | Gets or sets the bitmap object representing an image that will be drawn on a document.
ImageData | Gets or sets the hexascii data string representing a sampled image.
ImageFilePath | Gets or sets the absolute path and file name of an image file to load.
ImageMatrix | Gets or sets a transformation matrix that can be used to manipulate the image. [w 0 0 –h 0 h] are normal values.
Interpolate | Gets or sets a value that determines whether PostScript should interpolate image colors that cannot be found.
Name | Gets or sets the name of this image. This is the name to use when calling WriteImage().
Width | Gets or sets the actual width of this image in pixels.

Public Instance Methods

CreateHexAsciiImageFileC | Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHexAsciiDataC | Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.
GetType (inherited from Object) | Gets the Type of the current instance.
ScaleImage | Scales the image to the values specified. No attempt is made to keep the original aspect ratio.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage Constructor

Returns a new default image object.

Overload List

Returns a new default image object.

public PSImage();

Returns a new PSImage object whose bitmap is set.

public PSImage(Bitmap,string);

Returns a new PSImage object given a file path and loads the bitmap into memory.

public PSImage(string,string);

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage Constructor ()

Returns a new default image object.

[Visual Basic]
Overloads Public Sub New()
[C#]
public PSImage();

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace | PSImage Constructor Overload List


PSImage Constructor (Bitmap, String)

Returns a new PSImage object whose bitmap is set.

[Visual Basic]
Overloads Public Sub New( _
ByVal b As Bitmap, _
ByVal name As String _
)
[C#]
public PSImage(
Bitmap b,
string name
);

Parameters

b
The bitmap object you want to embed into the document.
name
The name of the image you will use when calling WriteImage().

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace | PSImage Constructor Overload List


PSImage Constructor (String, String)

Returns a new PSImage object given a file path and loads the bitmap into memory.

[Visual Basic]
Overloads Public Sub New( _
ByVal filePathAndName As String, _
ByVal name As String _
)
[C#]
public PSImage(
string filePathAndName,
string name
);

Parameters

filePathAndName
Path and file name to an image file.
name
The name of the image you will use when calling WriteImage().

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace | PSImage Constructor Overload List


PSImage Properties

The properties of the PSImage class are listed below. For a complete list of PSImage class members, see the PSImage Members topic.

Public Instance Properties

DecodeMatrix | Gets or sets the transformation matrix to use for decoding this image. Normally you will not have to change this object.
Height | Gets or sets the actual height of this image in pixels.
Image | Gets or sets the bitmap object representing an image that will be drawn on a document.
ImageData | Gets or sets the hexascii data string representing a sampled image.
ImageFilePath | Gets or sets the absolute path and file name of an image file to load.
ImageMatrix | Gets or sets a transformation matrix that can be used to manipulate the image. [w 0 0 –h 0 h] are normal values.
Interpolate | Gets or sets a value that determines whether PostScript should interpolate image colors that cannot be found.
Name | Gets or sets the name of this image. This is the name to use when calling WriteImage().
Width | Gets or sets the actual width of this image in pixels.

See Also

PSImage Class | PSWriteNetLib Namespace


DecodeMatrix Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.DecodeMatrix Property

Gets or sets the transformation matrix to use for decoding this image. Normally you will not have to change this object.

[Visual Basic]
Public Property DecodeMatrix As TMatrix
[C#]
public TMatrix DecodeMatrix {get; set;}

Property Value

Remarks

Images sampled with this class require the following matrix [0 1 0 1 0 1]. This special matrix tells PostScript how the image was sampled so that it can recreate it in the same way as it was sampled. Images sampled with this class are scanned top to bottom and left to right. Do not change this setting unless you are using images sampled in a different order.

See Also

PSImage Class | PSWriteNetLib Namespace


Height Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.Height Property

Gets or sets the actual height of this image in pixels.

[Visual Basic]
Public Property Height As Integer
[C#]
public int Height {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


Image Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.Image Property

Gets or sets the bitmap object representing an image that will be drawn on a document.

[Visual Basic]
Public Property Image As Bitmap
[C#]
public System.Drawing.Bitmap Image {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


ImageData Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.ImageData Property

Gets or sets the hexascii data string representing a sampled image.

[Visual Basic]
Public Property ImageData As String
[C#]
public string ImageData {get; set;}

Property Value

Remarks

This string is used by PostScipt to draw the original image onto a page.

See Also

PSImage Class | PSWriteNetLib Namespace


ImageFilePath Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.ImageFilePath Property

Gets or sets the absolute path and file name of an image file to load.

[Visual Basic]
Public Property ImageFilePath As String
[C#]
public string ImageFilePath {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


ImageMatrix Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.ImageMatrix Property

Gets or sets a transformation matrix that can be used to manipulate the image. [w 0 0 –h 0 h] are normal values.

[Visual Basic]
Public Property ImageMatrix As TMatrix
[C#]
public TMatrix ImageMatrix {get; set;}

Property Value

Remarks

This matrix can be used to translate(move), to scale or to rotate the image within its container. A normal matrix, sampled by this class, would have values matching the images height and width. [w 0 0 –h 0 h]. The normal matrix does not alter the image in any way.

See Also

PSImage Class | PSWriteNetLib Namespace


Interpolate Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.Interpolate Property

Gets or sets a value that determines whether PostScript should interpolate image colors that cannot be found.

[Visual Basic]
Public Property Interpolate As Boolean
[C#]
public bool Interpolate {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


Name Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.Name Property

Gets or sets the name of this image. This is the name to use when calling WriteImage().

[Visual Basic]
Public Property Name As String
[C#]
public string Name {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


Width Property

PSWriteNetLib For CLR 1.1 Documentation

PSImage.Width Property

Gets or sets the actual width of this image in pixels.

[Visual Basic]
Public Property Width As Integer
[C#]
public int Width {get; set;}

Property Value

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage Methods

The methods of the PSImage class are listed below. For a complete list of PSImage class members, see the PSImage Members topic.

Public Static (Shared) Methods

CreateHexAsciiImageFile | Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.
GetHexAsciiData | Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.

Public Instance Methods

CreateHexAsciiImageFileC | Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetHexAsciiDataC | Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.
GetType (inherited from Object) | Gets the Type of the current instance.
ScaleImage | Scales the image to the values specified. No attempt is made to keep the original aspect ratio.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage.CreateHexAsciiImageFile Method

Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.

[Visual Basic]
Public Shared Sub CreateHexAsciiImageFile( _
ByVal picFile As String, _
ByVal outputPathAndFileName As String _
)
[C#]
public static void CreateHexAsciiImageFile(
string picFile,
string outputPathAndFileName
);

Parameters

picFile
The existing image file containing an image to convert to hex ascii.
outputPathAndFileName
The path and filename to create that contains the image describing in picFile.

Remarks

Use of the *.hexascii file nameing convention is recommended. The file created by this method contains the data of the image. The correct image matrix in the image dictionary for images sampled with this method is: [w 0 0 –h 0 h]. Images are scanned top to bottom and left to right.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage.CreateHexAsciiImageFileC Method

Creates a hex ascii text file called 'outputPathAndFileName' that contains the data of image file 'picfile' in a form useable by PostScript.

[Visual Basic]
Public Sub CreateHexAsciiImageFileC( _
ByVal picFile As String, _
ByVal outputPathAndFileName As String _
)
[C#]
public void CreateHexAsciiImageFileC(
string picFile,
string outputPathAndFileName
);

Parameters

picFile
The existing image file containing an image to convert to hex ascii.
outputPathAndFileName
The path and filename to create that contains the image describing in picFile.

Remarks

Use of the *.hexascii file nameing convention is recommended. The file created by this method contains the data of the image and can be used by the accqusition procedure. The correct image matrix in the image dictionary for images sampled with this method is: [w 0 0 –h 0 h]. Images are scanned top to bottom and left to right.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage.GetHexAsciiData Method

Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.

[Visual Basic]
Public Shared Function GetHexAsciiData( _
ByVal imagePathAndFileName As String _
) As String
[C#]
public static string GetHexAsciiData(
string imagePathAndFileName
);

Parameters

imagePathAndFileName
Path and file name of an image file. Supported images (.bmp, .gif, .jpg, .png).

Return Value

String of hex ascii data representing the image.

Remarks

The correct image matrix in the image dictionary for images sampled with this method is: [w 0 0 –h 0 h]. Images are scanned top to bottom and left to right.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage.GetHexAsciiDataC Method

Gets a string of hex ascii data in the form needed by PostScript given a path to an image file. Image files of .bmp, .gif, .jpg or .png are supported. The returned string can be directly embedded into a PostScript form or document.

[Visual Basic]
Public Function GetHexAsciiDataC( _
ByVal imagePathAndFileName As String _
) As String
[C#]
public string GetHexAsciiDataC(
string imagePathAndFileName
);

Parameters

imagePathAndFileName
Path and file name of an image file. Supported images (.bmp, .gif, .jpg, .png).

Return Value

String of hex ascii data representing the image.

Remarks

The string returned by this function can be directly embedded into a PostScript source file in the data accqusition procedure. The correct image matrix in the image dictionary for images sampled with this method is: [w 0 0 –h 0 h]. Images are scanned top to bottom and left to right.

See Also

PSImage Class | PSWriteNetLib Namespace


PSImage.ScaleImage Method

Scales the image to the values specified. No attempt is made to keep the original aspect ratio.

[Visual Basic]
Public Sub ScaleImage( _
ByVal width As Single, _
ByVal height As Single _
)
[C#]
public void ScaleImage(
float width,
float height
);

Parameters

width
Desired width of the image in points.
height
Desired height of the image in points.

Remarks

See Also

PSImage Class | PSWriteNetLib Namespace


TMatrix Class

Provides a transformation matrix object that can manipulate the current user space to do translations(moving the point of origin), scaling and rotations about the point of origin.

For a list of all members of this type, see TMatrix Members.

System.Object
PSWriteNetLib.TMatrix

[Visual Basic]
Public Class TMatrix
[C#]
public class TMatrix

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Remarks

Use TMatrix to manipulate the current user space in the PostScript document. A matrix of [1 0 0 1 Tx Ty] will translate (move the point of origin) to Tx Ty. A matrix of [Sx 0 0 Sy 0 0] will scale the user space by Sx in the horizontal plane and by Sy in the vertical plane. A matrix of [cosineDg sineDg -cosineDg sineDg 0 0] will rotate the user space by Dg degrees about the current point of origin.

Requirements

Namespace: PSWriteNetLib

Assembly: PSWriteNet (in PSWriteNet.dll)

See Also

TMatrix Members | PSWriteNetLib Namespace


TMatrix Members

TMatrix overview

Public Instance Constructors

TMatrix Constructor Gets a new TMatrix object with its members already set. Use TMatrix to scale, translate and rotate user space.

Public Instance Properties

A
B
C
D
Tx
Ty

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

TMatrix Class | PSWriteNetLib Namespace


TMatrix Constructor

Gets a new TMatrix object with its members already set. Use TMatrix to scale, translate and rotate user space.

[Visual Basic]
Public Sub New( _
ByVal a As Single, _
ByVal b As Single, _
ByVal c As Single, _
ByVal d As Single, _
ByVal Tx As Single, _
ByVal Ty As Single _
)
[C#]
public TMatrix(
float a,
float b,
float c,
float d,
float Tx,
float Ty
);

Parameters

a
First transformation value.
b
Second transformation value.
c
Third transformation value.
d
Fourth transformation value.
Tx
Fifth transformation value.
Ty
Sixth transformation value.

Remarks

Use TMatrix to manipulate the current user space in the PostScript document. A matrix of [1 0 0 1 Tx Ty] will translate (move the point of origin) to Tx Ty. A matrix of [Sx 0 0 Sy 0 0] will scale the user space by Sx in the horizontal plane and by Sy in the vertical plane. A matrix of [cosineDg sineDg -cosineDg sineDg 0 0] will rotate the user space by Dg degrees about the current point of origin.

See Also

TMatrix Class | PSWriteNetLib Namespace


TMatrix Properties

The properties of the TMatrix class are listed below. For a complete list of TMatrix class members, see the TMatrix Members topic.

Public Instance Properties

A
B
C
D
Tx
Ty

See Also

TMatrix Class | PSWriteNetLib Namespace


A Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.A Property

[Visual Basic]
Public ReadOnly Property A As Single
[C#]
public float A {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


B Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.B Property

[Visual Basic]
Public ReadOnly Property B As Single
[C#]
public float B {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


C Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.C Property

[Visual Basic]
Public ReadOnly Property C As Single
[C#]
public float C {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


D Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.D Property

[Visual Basic]
Public ReadOnly Property D As Single
[C#]
public float D {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


Tx Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.Tx Property

[Visual Basic]
Public ReadOnly Property Tx As Single
[C#]
public float Tx {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


Ty Property

PSWriteNetLib For CLR 1.1 Documentation

TMatrix.Ty Property

[Visual Basic]
Public ReadOnly Property Ty As Single
[C#]
public float Ty {get;}

See Also

TMatrix Class | PSWriteNetLib Namespace


PSWriteNetLibHierarchy

PSWriteNetLib For CLR 1.1 Documentation

PSWriteNetLib Hierarchy

System.Object
PSWriteNetLib.BoundingBox
PSWriteNetLib.PointS
PSWriteNetLib.PSColor
PSWriteNetLib.PSDocument
PSWriteNetLib.PSFormBase
PSWriteNetLib.PSForm
PSWriteNetLib.PSImage
PSWriteNetLib.TMatrix
System.Delegate ---- System.ICloneable, System.Runtime.Serialization.ISerializable
System.MulticastDelegate
PSWriteNetLib.PSDocument.Document_CompleteEventHandler
PSWriteNetLib.PSDocument.NewPage_CreatedEventHandler
System.EventArgs
PSWriteNetLib.DocumentCompleteEventArgs
PSWriteNetLib.PageCreatedEventArgs
System.ValueType
PSWriteNetLib.PSDocument.PieChart
PSWriteNetLib.PSDocument.PieChartSlice
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
PSWriteNetLib.PSDocument.DocumentOrientation
PSWriteNetLib.PSDocument.LineCap
PSWriteNetLib.PSDocument.LineJoin
PSWriteNetLib.PSDocument.PaperSize

See Also

PSWriteNetLib Namespace